summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authortycho <work.tycho@gmail.com>2015-05-28 12:05:41 +0200
committertycho <work.tycho@gmail.com>2015-05-28 12:05:41 +0200
commite19693e529bf26e62a54f60c167d1b4870d7d44a (patch)
tree0b2cb131fa2f009723dd0ecd739ff911a369c763 /src/CMakeLists.txt
parentFix warnings in cPath (diff)
parentMerge pull request #2151 from SafwatHalaby/wolf (diff)
downloadcuberite-e19693e529bf26e62a54f60c167d1b4870d7d44a.tar
cuberite-e19693e529bf26e62a54f60c167d1b4870d7d44a.tar.gz
cuberite-e19693e529bf26e62a54f60c167d1b4870d7d44a.tar.bz2
cuberite-e19693e529bf26e62a54f60c167d1b4870d7d44a.tar.lz
cuberite-e19693e529bf26e62a54f60c167d1b4870d7d44a.tar.xz
cuberite-e19693e529bf26e62a54f60c167d1b4870d7d44a.tar.zst
cuberite-e19693e529bf26e62a54f60c167d1b4870d7d44a.zip
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index dba6822c2..a23e02789 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -364,4 +364,9 @@ endif ()
if (WIN32)
target_link_libraries(${EXECUTABLE} expat tolualib ws2_32.lib Psapi.lib)
endif()
+
+if (${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")
+ add_flags_lnk(-L/usr/local/lib)
+endif()
+
target_link_libraries(${EXECUTABLE} luaexpat jsoncpp mbedtls zlib sqlite lua SQLiteCpp event_core event_extra)