summaryrefslogtreecommitdiffstats
path: root/src/Protocol/CMakeLists.txt
diff options
context:
space:
mode:
authorLukas Pioch <lukas@zgow.de>2017-06-14 11:22:51 +0200
committerGitHub <noreply@github.com>2017-06-14 11:22:51 +0200
commit5a228fbc16c0b89e14b5fbf9940230f261c76c13 (patch)
treec43ada5f63b105e11ac6e902d9e5cdd42764af4d /src/Protocol/CMakeLists.txt
parentRemove redundant heighmap code (diff)
downloadcuberite-5a228fbc16c0b89e14b5fbf9940230f261c76c13.tar
cuberite-5a228fbc16c0b89e14b5fbf9940230f261c76c13.tar.gz
cuberite-5a228fbc16c0b89e14b5fbf9940230f261c76c13.tar.bz2
cuberite-5a228fbc16c0b89e14b5fbf9940230f261c76c13.tar.lz
cuberite-5a228fbc16c0b89e14b5fbf9940230f261c76c13.tar.xz
cuberite-5a228fbc16c0b89e14b5fbf9940230f261c76c13.tar.zst
cuberite-5a228fbc16c0b89e14b5fbf9940230f261c76c13.zip
Diffstat (limited to 'src/Protocol/CMakeLists.txt')
-rw-r--r--src/Protocol/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Protocol/CMakeLists.txt b/src/Protocol/CMakeLists.txt
index dd24c710a..f21c81f83 100644
--- a/src/Protocol/CMakeLists.txt
+++ b/src/Protocol/CMakeLists.txt
@@ -11,6 +11,7 @@ SET (SRCS
Protocol_1_9.cpp
Protocol_1_10.cpp
Protocol_1_11.cpp
+ Protocol_1_12.cpp
ProtocolRecognizer.cpp
)
@@ -24,6 +25,7 @@ SET (HDRS
Protocol_1_9.h
Protocol_1_10.h
Protocol_1_11.h
+ Protocol_1_12.h
ProtocolRecognizer.h
)
@@ -32,6 +34,7 @@ if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
set_source_files_properties(Protocol_1_8.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=switch")
set_source_files_properties(Protocol_1_10.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=switch")
set_source_files_properties(Protocol_1_11.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=switch")
+ set_source_files_properties(Protocol_1_12.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=switch")
endif()
if (NOT MSVC)