summaryrefslogtreecommitdiffstats
path: root/tests/BlockTypeRegistry/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2019-08-23 16:17:05 +0200
committerMattes D <github@xoft.cz>2019-08-24 12:03:38 +0200
commit02fbf1686565ace00df5af938d95fbe18783fc37 (patch)
treee109749b5823f758d605dd2a8f5d2c8b8b22878b /tests/BlockTypeRegistry/CMakeLists.txt
parentUpgrade Appveyor's MSVC (diff)
downloadcuberite-02fbf1686565ace00df5af938d95fbe18783fc37.tar
cuberite-02fbf1686565ace00df5af938d95fbe18783fc37.tar.gz
cuberite-02fbf1686565ace00df5af938d95fbe18783fc37.tar.bz2
cuberite-02fbf1686565ace00df5af938d95fbe18783fc37.tar.lz
cuberite-02fbf1686565ace00df5af938d95fbe18783fc37.tar.xz
cuberite-02fbf1686565ace00df5af938d95fbe18783fc37.tar.zst
cuberite-02fbf1686565ace00df5af938d95fbe18783fc37.zip
Diffstat (limited to 'tests/BlockTypeRegistry/CMakeLists.txt')
-rw-r--r--tests/BlockTypeRegistry/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/BlockTypeRegistry/CMakeLists.txt b/tests/BlockTypeRegistry/CMakeLists.txt
index 25b18c373..c95c503dd 100644
--- a/tests/BlockTypeRegistry/CMakeLists.txt
+++ b/tests/BlockTypeRegistry/CMakeLists.txt
@@ -11,6 +11,16 @@ add_definitions(-DTEST_GLOBALS=1)
# Define individual test executables:
+# BlockStateTest: Verify that the BlockState class works as intended:
+add_executable(BlockStateTest
+ BlockStateTest.cpp
+ ../TestHelpers.h
+ ${CMAKE_SOURCE_DIR}/src/BlockState.cpp
+ ${CMAKE_SOURCE_DIR}/src/StringUtils.cpp
+ ${CMAKE_SOURCE_DIR}/src/OSSupport/CriticalSection.cpp
+)
+target_link_libraries(BlockStateTest fmt::fmt)
+
# BlockTypeRegistryTest: Verify that the BlockTypeRegistry class works as intended:
add_executable(BlockTypeRegistryTest
BlockTypeRegistryTest.cpp
@@ -25,8 +35,10 @@ target_link_libraries(BlockTypeRegistryTest fmt::fmt)
+
# Define individual tests:
+add_test(NAME BlockStateTest COMMAND BlockStateTest)
add_test(NAME BlockTypeRegistryTest COMMAND BlockTypeRegistryTest)
@@ -35,6 +47,7 @@ add_test(NAME BlockTypeRegistryTest COMMAND BlockTypeRegistryTest)
# Put all the tests into a solution folder (MSVC):
set_target_properties(
+ BlockStateTest
BlockTypeRegistryTest
PROPERTIES FOLDER Tests/BlockTypeRegistry
)