summaryrefslogtreecommitdiffstats
path: root/tests/Redstone/CMakeLists.txt
diff options
context:
space:
mode:
authorTycho <work.tycho+git@gmail.com>2014-09-17 19:40:10 +0200
committerTycho <work.tycho+git@gmail.com>2014-09-17 19:40:10 +0200
commit6e7c0e33b5dd6d86d66ac2eb1a07a33652a708fd (patch)
tree69681d2a6bd1f3572305f7120d9231b394ac9c88 /tests/Redstone/CMakeLists.txt
parentIncrementalRedstoneSimulator now has no dependencies on cChunk (diff)
downloadcuberite-6e7c0e33b5dd6d86d66ac2eb1a07a33652a708fd.tar
cuberite-6e7c0e33b5dd6d86d66ac2eb1a07a33652a708fd.tar.gz
cuberite-6e7c0e33b5dd6d86d66ac2eb1a07a33652a708fd.tar.bz2
cuberite-6e7c0e33b5dd6d86d66ac2eb1a07a33652a708fd.tar.lz
cuberite-6e7c0e33b5dd6d86d66ac2eb1a07a33652a708fd.tar.xz
cuberite-6e7c0e33b5dd6d86d66ac2eb1a07a33652a708fd.tar.zst
cuberite-6e7c0e33b5dd6d86d66ac2eb1a07a33652a708fd.zip
Diffstat (limited to 'tests/Redstone/CMakeLists.txt')
-rw-r--r--tests/Redstone/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/Redstone/CMakeLists.txt b/tests/Redstone/CMakeLists.txt
new file mode 100644
index 000000000..ee4a7a64f
--- /dev/null
+++ b/tests/Redstone/CMakeLists.txt
@@ -0,0 +1,10 @@
+cmake_minimum_required (VERSION 2.6)
+
+enable_testing()
+
+include_directories(${CMAKE_SOURCE_DIR}/src/)
+
+add_definitions(-DTEST_GLOBALS=1)
+
+add_executable(Redstone-creatable-exe creatable.cpp ../../src/BoundingBox.cpp)
+add_test(NAME creatable-test COMMAND Redstone-creatable-exe)