summaryrefslogtreecommitdiffstats
path: root/Tools/GeneratorPerformanceTest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tools/GeneratorPerformanceTest/CMakeLists.txt')
-rw-r--r--Tools/GeneratorPerformanceTest/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Tools/GeneratorPerformanceTest/CMakeLists.txt b/Tools/GeneratorPerformanceTest/CMakeLists.txt
new file mode 100644
index 000000000..8adc88882
--- /dev/null
+++ b/Tools/GeneratorPerformanceTest/CMakeLists.txt
@@ -0,0 +1,12 @@
+
+cmake_minimum_required(VERSION 2.8)
+project(GeneratorPerformanceTest)
+
+include_directories(../../src/Generating)
+include_directories(../../src)
+include_directories(../../lib)
+
+add_executable(GeneratorPerformanceTest GeneratorPerformanceTest.cpp ../../src/StringUtils ../../src/MCLogger ../../src/Log ../../src/BlockID ../../src/Noise ../../src/Enchantments ../../src/BlockArea)
+
+target_link_libraries(GeneratorPerformanceTest Generating)
+