summaryrefslogtreecommitdiffstats
path: root/lib/cryptopp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/cryptopp/CMakeLists.txt')
-rw-r--r--lib/cryptopp/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/lib/cryptopp/CMakeLists.txt b/lib/cryptopp/CMakeLists.txt
index daa16ca53..e0e65c818 100644
--- a/lib/cryptopp/CMakeLists.txt
+++ b/lib/cryptopp/CMakeLists.txt
@@ -7,4 +7,9 @@ if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
endif()
include_directories ("${PROJECT_SOURCE_DIR}/../../src/")
-add_library(cryptopp rsa integer queue secblock misc randpool pch asn oids modarith nbtheory sha algparam fips140 pssr aes hrtimer cryptlib filters pubkey algebra simple pkcspad iterhash emsa2 eprecomp cpu rijndael)
+file(GLOB cryptopp_SRC
+ "*.h"
+ "*.cpp"
+)
+
+add_library(cryptopp ${cryptopp_SRC})