summaryrefslogtreecommitdiffstats
path: root/lib/expat/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/expat/CMakeLists.txt')
-rw-r--r--lib/expat/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/lib/expat/CMakeLists.txt b/lib/expat/CMakeLists.txt
index df9e8d57c..667804b9a 100644
--- a/lib/expat/CMakeLists.txt
+++ b/lib/expat/CMakeLists.txt
@@ -2,10 +2,15 @@
cmake_minimum_required (VERSION 2.6)
project (expat)
-include_directories ("${PROJECT_SOURCE_DIR}/../../src/")
-
file(GLOB SOURCE
"*.c"
)
+# add headers to MSVC project files:
+if (WIN32)
+ file(GLOB HEADERS "*.h")
+ set(SOURCE ${SOURCE} ${HEADERS})
+ source_group("Sources" FILES ${SOURCE})
+endif()
+
add_library(expat ${SOURCE})