summaryrefslogtreecommitdiffstats
path: root/lib/tolua++/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/tolua++/CMakeLists.txt')
-rw-r--r--lib/tolua++/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/lib/tolua++/CMakeLists.txt b/lib/tolua++/CMakeLists.txt
new file mode 100644
index 000000000..2b071108c
--- /dev/null
+++ b/lib/tolua++/CMakeLists.txt
@@ -0,0 +1,17 @@
+
+cmake_minimum_required (VERSION 2.6)
+project (tolua++)
+
+include_directories ("${PROJECT_SOURCE_DIR}/../../src/")
+include_directories ("${PROJECT_SOURCE_DIR}/include/")
+include_directories ("${PROJECT_SOURCE_DIR}/../")
+
+file(GLOB SOURCE
+ "src/bin/*.c"
+ "src/lib/*.c"
+)
+
+add_executable(tolua ${SOURCE})
+
+#m is the standard math librarys
+target_link_libraries(tolua lua m)