summaryrefslogtreecommitdiffstats
path: root/src/Items/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Items/CMakeLists.txt')
-rw-r--r--src/Items/CMakeLists.txt10
1 files changed, 2 insertions, 8 deletions
diff --git a/src/Items/CMakeLists.txt b/src/Items/CMakeLists.txt
index 9deec08c7..e5f65fb3b 100644
--- a/src/Items/CMakeLists.txt
+++ b/src/Items/CMakeLists.txt
@@ -1,9 +1,8 @@
+target_sources(
+ ${CMAKE_PROJECT_NAME} PRIVATE
-SET (SRCS
ItemHandler.cpp
-)
-SET (HDRS
ItemArmor.h
ItemAxe.h
ItemBed.h
@@ -62,8 +61,3 @@ SET (HDRS
ItemSword.h
ItemThrowable.h
)
-
-if(NOT MSVC)
- add_library(Items ${SRCS} ${HDRS})
- target_link_libraries(Items fmt::fmt SQLiteCpp)
-endif()