summaryrefslogtreecommitdiffstats
path: root/src/OSSupport/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/OSSupport/CMakeLists.txt')
-rw-r--r--src/OSSupport/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/OSSupport/CMakeLists.txt b/src/OSSupport/CMakeLists.txt
index 429949c59..a2f46d656 100644
--- a/src/OSSupport/CMakeLists.txt
+++ b/src/OSSupport/CMakeLists.txt
@@ -38,7 +38,11 @@ SET (HDRS
if(NOT MSVC)
add_library(OSSupport ${SRCS} ${HDRS})
- if(UNIX)
- target_link_libraries(OSSupport pthread rt)
+ if(NOT APPLE)
+ target_link_libraries(OSSupport rt)
endif()
+
+ if(UNIX)
+ target_link_libraries(OSSupport pthread)
+ endif()
endif()