summaryrefslogtreecommitdiffstats
path: root/tests/Network/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Network/CMakeLists.txt')
-rw-r--r--tests/Network/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/Network/CMakeLists.txt b/tests/Network/CMakeLists.txt
index 12759558e..8bbe6294d 100644
--- a/tests/Network/CMakeLists.txt
+++ b/tests/Network/CMakeLists.txt
@@ -1,6 +1,8 @@
include_directories(${CMAKE_SOURCE_DIR}/src/)
include_directories(SYSTEM ${CMAKE_SOURCE_DIR}/lib/mbedtls/include)
+find_package(Threads REQUIRED)
+
# Create a single Network library that contains all the networking code:
set (Network_SRCS
${CMAKE_SOURCE_DIR}/src/OSSupport/CriticalSection.cpp
@@ -54,10 +56,8 @@ add_library(Network
)
target_link_libraries(Network event_core event_extra fmt::fmt mbedtls)
-if (WIN32)
- target_link_libraries(Network ws2_32.lib)
-else()
- target_link_libraries(Network event_pthreads_static)
+if(NOT WIN32)
+ target_link_libraries(Network event_pthreads Threads::Threads)
endif()