summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@flameeyes.com>2020-10-04 16:12:44 +0200
committermergify[bot] <37929162+mergify[bot]@users.noreply.github.com>2020-10-04 21:47:57 +0200
commit81d4e308a36cd06f5e7bac30d2af10145c8f193a (patch)
treeacf5314486de90f79ec4b77b423f282e7a9afaa4 /setup.py
parenttd4277: update dependency information for pyserial. (diff)
downloadglucometerutils-81d4e308a36cd06f5e7bac30d2af10145c8f193a.tar
glucometerutils-81d4e308a36cd06f5e7bac30d2af10145c8f193a.tar.gz
glucometerutils-81d4e308a36cd06f5e7bac30d2af10145c8f193a.tar.bz2
glucometerutils-81d4e308a36cd06f5e7bac30d2af10145c8f193a.tar.lz
glucometerutils-81d4e308a36cd06f5e7bac30d2af10145c8f193a.tar.xz
glucometerutils-81d4e308a36cd06f5e7bac30d2af10145c8f193a.tar.zst
glucometerutils-81d4e308a36cd06f5e7bac30d2af10145c8f193a.zip
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 3 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index cbe985e..115a0ad 100644
--- a/setup.py
+++ b/setup.py
@@ -12,18 +12,16 @@ extras_require = {
# listed as mandatory for the feature.
"accucheck_reports": [],
"contourusb": ["construct", "hidapi"],
- "fsinsulinx": ["construct", "hidapi"],
- "fslibre": ["construct", "hidapi"],
+ "fsinsulinx": ["freestyle_hid"],
+ "fslibre": ["freestyle_hid"],
"fsoptium": ["pyserial"],
- "fsprecisionneo": ["construct", "hidapi"],
+ "fsprecisionneo": ["freestyle_hid"],
"otultra2": ["pyserial"],
"otultraeasy": ["construct", "pyserial"],
"otverio2015": ["construct", "PYSCSI[sgio]>=2.0.1"],
"otverioiq": ["construct", "pyserial"],
"sdcodefree": ["construct", "pyserial"],
"td4277": ["construct", "pyserial[cp2110]>=3.5b0"],
- # These are not drivers, but rather tools and features.
- "reversing_tools": ["usbmon-tools"],
"dev": [
"absl-py",
"construct>=2.9",