summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 7 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 046a422..c9236fd 100644
--- a/setup.py
+++ b/setup.py
@@ -49,15 +49,15 @@ setup(
# These are all the drivers' dependencies. Optional dependencies are
# listed as mandatory for the feature.
'otultra2': ['pyserial'],
- 'otultraeasy': ['construct>=2.8,<2.9', 'pyserial'],
- 'otverio2015': ['construct>=2.8,<2.9', 'python-scsi'],
- 'otverioiq': ['construct>=2.8,<2.9', 'pyserial'],
- 'fsinsulinx': ['construct>=2.8,<2.9', 'hidapi'],
- 'fslibre': ['construct>=2.8,<2.9', 'hidapi'],
+ 'otultraeasy': ['construct==2.8.22', 'pyserial'],
+ 'otverio2015': ['construct==2.8.22', 'python-scsi'],
+ 'otverioiq': ['construct==2.8.22', 'pyserial'],
+ 'fsinsulinx': ['construct==2.8.22', 'hidapi'],
+ 'fslibre': ['construct==2.8.22', 'hidapi'],
'fsoptium': ['pyserial'],
- 'fsprecisionneo': ['construct>=2.8,<2.9', 'hidapi'],
+ 'fsprecisionneo': ['construct==2.8.22', 'hidapi'],
'accucheck_reports': [],
- 'sdcodefree': ['construct>=2.8,<2.9', 'pyserial'],
+ 'sdcodefree': ['construct==2.8.22', 'pyserial'],
},
entry_points = {
'console_scripts': [