summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorHeiner Lohaus <hlohaus@users.noreply.github.com>2024-01-12 02:14:35 +0100
committerHeiner Lohaus <hlohaus@users.noreply.github.com>2024-01-12 02:14:35 +0100
commita7c856592213c8a8c7a6ef3b30cccf2ede6a9636 (patch)
tree6f2107ce9057c2da9a30e3fd33ff247d30a3e199 /setup.py
parentFix create_async in CreateImagesProvider (diff)
downloadgpt4free-a7c856592213c8a8c7a6ef3b30cccf2ede6a9636.tar
gpt4free-a7c856592213c8a8c7a6ef3b30cccf2ede6a9636.tar.gz
gpt4free-a7c856592213c8a8c7a6ef3b30cccf2ede6a9636.tar.bz2
gpt4free-a7c856592213c8a8c7a6ef3b30cccf2ede6a9636.tar.lz
gpt4free-a7c856592213c8a8c7a6ef3b30cccf2ede6a9636.tar.xz
gpt4free-a7c856592213c8a8c7a6ef3b30cccf2ede6a9636.tar.zst
gpt4free-a7c856592213c8a8c7a6ef3b30cccf2ede6a9636.zip
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py39
1 files changed, 34 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 0bb683e4..dc59597b 100644
--- a/setup.py
+++ b/setup.py
@@ -8,10 +8,39 @@ here = os.path.abspath(os.path.dirname(__file__))
with codecs.open(os.path.join(here, 'README.md'), encoding='utf-8') as fh:
long_description = '\n' + fh.read()
-with open('requirements.txt') as f:
- required = f.read().splitlines()
+install_requires = [
+ "requests",
+ "pycryptodome",
+ "curl_cffi>=0.5.10",
+ "aiohttp",
+ "certifi",
+ "browser_cookie3",
+ "websockets",
+ "js2py",
+ "typing-extensions",
+ "PyExecJS",
+ "duckduckgo-search",
+ "nest_asyncio",
+ "waitress",
+ "werkzeug",
+ "loguru",
+ "pillow",
+ "platformdirs",
+ "numpy",
+ "asgiref",
+ "fastapi",
+ "uvicorn",
+ "flask",
+ "py-arkose-generator",
+ "asyncstdlib",
+ "async-property",
+ "undetected-chromedriver",
+ "asyncstdlib",
+ "async_property",
+ "brotli",
+ "beautifulsoup4",
+]
-VERSION = '0.1.9.9'
DESCRIPTION = (
'The official gpt4free repository | various collection of powerful language models'
)
@@ -19,7 +48,7 @@ DESCRIPTION = (
# Setting up
setup(
name='g4f',
- version=VERSION,
+ version=os.environ.get("G4F_VERSION"),
author='Tekky',
author_email='<support@g4f.ai>',
description=DESCRIPTION,
@@ -30,7 +59,7 @@ setup(
'g4f': ['g4f/interference/*', 'g4f/gui/client/*', 'g4f/gui/server/*', 'g4f/Provider/npm/*']
},
include_package_data=True,
- install_requires=required,
+ install_requires=install_requires,
entry_points={
'console_scripts': ['g4f=g4f.cli:main'],
},