summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..5b98934
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 2.8.12)
+
+project(tinyaes C ASM)
+
+add_library(tiny-aes
+ aes.c
+ )
+
+target_compile_definitions(tiny-aes PRIVATE
+ -DAES128=1
+ -DCBC=1
+ -DECB=1
+ -DCTR=1
+ )
+
+target_include_directories(tiny-aes PRIVATE tiny-AES-c/)