summaryrefslogtreecommitdiffstats
path: root/www-apps/searc/searc-0.0.27.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/searc/searc-0.0.27.ebuild')
-rw-r--r--www-apps/searc/searc-0.0.27.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/www-apps/searc/searc-0.0.27.ebuild b/www-apps/searc/searc-0.0.27.ebuild
new file mode 100644
index 0000000..c9b522c
--- /dev/null
+++ b/www-apps/searc/searc-0.0.27.ebuild
@@ -0,0 +1,31 @@
+EAPI=8
+
+# max 80 chars
+DESCRIPTION="scraper for search results of popular engines, caches them and creates a HTML UI"
+HOMEPAGE="http://ni.sijanec.eu./sijanec/sear.c"
+SRC_URI="http://ni.sijanec.eu./sijanec/sear.c/snapshot/sear.c-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE=""
+SLOT="0"
+IUSE="oldstorage logmem"
+
+# vsi moji programi so nestabilni (:
+KEYWORDS="*"
+
+DEPEND="dev-libs/libxml2 net-libs/libmicrohttpd acct-user/searc acct-group/searc"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+# do not use mirrors to download
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack ${A}
+ mv sear.c-${PV} searc-${PV}
+}
+
+src_compile() {
+ use oldstorage && append-flags "-DSC_OLD_STORAGE"
+ use logmem && append-flags "-DSC_LOGMEM"
+ emake
+}