summaryrefslogtreecommitdiffstats
path: root/heimdall/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'heimdall/Makefile.am')
-rw-r--r--heimdall/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/heimdall/Makefile.am b/heimdall/Makefile.am
index 930319a..7c87931 100644
--- a/heimdall/Makefile.am
+++ b/heimdall/Makefile.am
@@ -1,5 +1,5 @@
AUTOMAKE_OPTIONS = subdir-objects
-ACLOCAL_AMFLAGS = ${ACLOCAL_FLAGS}
+ACLOCAL_AMFLAGS = ${ACLOCAL_FLAGS}
AM_CPPFLAGS = $(DEPS_CFLAGS)
bin_PROGRAMS = heimdall
@@ -16,4 +16,12 @@ heimdall_SOURCES = source/BeginDumpPacket.h source/BridgeManager.cpp \
source/ResponsePacket.h source/SendFilePartPacket.h source/SendFilePartResponse.h
heimdall_LDADD = $(DEPS_LIBS)
-dist_noinst_SCRIPTS = autogen.sh \ No newline at end of file
+if LINUXTARGET
+udevrulesdir = /lib/udev/rules.d
+udevrules_DATA = 60-heimdall-galaxy-s.rules
+
+install-data-hook:
+ sudo service udev reload
+endif
+
+dist_noinst_SCRIPTS = autogen.sh