summaryrefslogtreecommitdiffstats
path: root/Tools/MCADefrag/CMakeLists.txt
diff options
context:
space:
mode:
authortycho <work.tycho@gmail.com>2015-05-24 17:58:53 +0200
committertycho <work.tycho@gmail.com>2015-05-24 18:14:35 +0200
commitc627016ea684d6d778499e05536da2217c0cff93 (patch)
tree648762ede483e35a69f59834c7f927fe5ecbe88a /Tools/MCADefrag/CMakeLists.txt
parentFix bearbins comments (diff)
downloadcuberite-c627016ea684d6d778499e05536da2217c0cff93.tar
cuberite-c627016ea684d6d778499e05536da2217c0cff93.tar.gz
cuberite-c627016ea684d6d778499e05536da2217c0cff93.tar.bz2
cuberite-c627016ea684d6d778499e05536da2217c0cff93.tar.lz
cuberite-c627016ea684d6d778499e05536da2217c0cff93.tar.xz
cuberite-c627016ea684d6d778499e05536da2217c0cff93.tar.zst
cuberite-c627016ea684d6d778499e05536da2217c0cff93.zip
Diffstat (limited to 'Tools/MCADefrag/CMakeLists.txt')
-rw-r--r--Tools/MCADefrag/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/Tools/MCADefrag/CMakeLists.txt b/Tools/MCADefrag/CMakeLists.txt
index 17e332d8d..9d600d3ec 100644
--- a/Tools/MCADefrag/CMakeLists.txt
+++ b/Tools/MCADefrag/CMakeLists.txt
@@ -12,8 +12,11 @@ set_lib_flags()
enable_profile()
if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
- add_flags_cxx("-Wno-error=sign-conversion -Wno-error=conversion -Wno-error=shorten-64-to-32 -Wno-error=keyword-macro")
+ add_flags_cxx("-Wno-error=sign-conversion -Wno-error=conversion -Wno-error=shorten-64-to-32")
add_flags_cxx("-Wno-error=old-style-cast")
+ if ("${CLANG_VERSION}" VERSION_GREATER 3.5)
+ add_flags_cxx("-Wno-error=keyword-macro")
+ endif()
endif()
# Set include paths to the used libraries: