summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2014-08-28 15:53:36 +0200
committerMattes D <github@xoft.cz>2014-08-28 15:53:36 +0200
commit52a6b30f324728aee1c1b8e54b8b4ed9c4e9b60c (patch)
treec7d8ad9c38a32102bd46e0450d271ea1308828ce /src/CMakeLists.txt
parentCheckBasicStyle: Added checking for the "template" keyword. (diff)
parentFixed ItemCategory code example. (diff)
downloadcuberite-52a6b30f324728aee1c1b8e54b8b4ed9c4e9b60c.tar
cuberite-52a6b30f324728aee1c1b8e54b8b4ed9c4e9b60c.tar.gz
cuberite-52a6b30f324728aee1c1b8e54b8b4ed9c4e9b60c.tar.bz2
cuberite-52a6b30f324728aee1c1b8e54b8b4ed9c4e9b60c.tar.lz
cuberite-52a6b30f324728aee1c1b8e54b8b4ed9c4e9b60c.tar.xz
cuberite-52a6b30f324728aee1c1b8e54b8b4ed9c4e9b60c.tar.zst
cuberite-52a6b30f324728aee1c1b8e54b8b4ed9c4e9b60c.zip
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt17
1 files changed, 8 insertions, 9 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index db9c61082..37657ba91 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,6 +1,7 @@
cmake_minimum_required (VERSION 2.8.2)
project (MCServer)
+
include_directories (SYSTEM "${CMAKE_CURRENT_SOURCE_DIR}/../lib/")
include_directories (SYSTEM "${CMAKE_CURRENT_SOURCE_DIR}/../lib/jsoncpp/include")
include_directories (SYSTEM "${CMAKE_CURRENT_SOURCE_DIR}/../lib/polarssl/include")
@@ -33,16 +34,14 @@ SET (SRCS
FastRandom.cpp
FurnaceRecipe.cpp
Globals.cpp
- Group.cpp
- GroupManager.cpp
Inventory.cpp
Item.cpp
ItemGrid.cpp
LightingThread.cpp
LineBlockTracer.cpp
LinearInterpolation.cpp
- Log.cpp
- MCLogger.cpp
+ LoggerListeners.cpp
+ Logger.cpp
Map.cpp
MapManager.cpp
MobCensus.cpp
@@ -52,6 +51,7 @@ SET (SRCS
MonsterConfig.cpp
Noise.cpp
ProbabDistrib.cpp
+ RankManager.cpp
RCONServer.cpp
Root.cpp
Scoreboard.cpp
@@ -97,8 +97,6 @@ SET (HDRS
ForEachChunkProvider.h
FurnaceRecipe.h
Globals.h
- Group.h
- GroupManager.h
Inventory.h
Item.h
ItemGrid.h
@@ -107,8 +105,8 @@ SET (HDRS
LineBlockTracer.h
LinearInterpolation.h
LinearUpscale.h
- Log.h
- MCLogger.h
+ Logger.h
+ LoggerListeners.h
Map.h
MapManager.h
Matrix4.h
@@ -121,6 +119,7 @@ SET (HDRS
MonsterConfig.h
Noise.h
ProbabDistrib.h
+ RankManager.h
RCONServer.h
Root.h
Scoreboard.h
@@ -234,7 +233,7 @@ endif()
# Generate a list of all source files:
-set(ALLFILES "")
+set(ALLFILES "${SRCS}" "${HDRS}")
foreach(folder ${FOLDERS})
get_directory_property(FOLDER_SRCS DIRECTORY ${folder} DEFINITION SRCS)
foreach (src ${FOLDER_SRCS})