summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorHowaner <franzi.moos@googlemail.com>2014-08-20 22:25:05 +0200
committerHowaner <franzi.moos@googlemail.com>2014-08-20 22:25:05 +0200
commitf7774ec33638bfc30cc29c1f70850a6072a31c93 (patch)
treec2c2896b87de9241b1555e4e2580aa6b3f401870 /src/CMakeLists.txt
parentRevert "Removes the fire if the block under the fire was broken." (diff)
parentMerge pull request #1335 from mc-server/CodeFixes (diff)
downloadcuberite-f7774ec33638bfc30cc29c1f70850a6072a31c93.tar
cuberite-f7774ec33638bfc30cc29c1f70850a6072a31c93.tar.gz
cuberite-f7774ec33638bfc30cc29c1f70850a6072a31c93.tar.bz2
cuberite-f7774ec33638bfc30cc29c1f70850a6072a31c93.tar.lz
cuberite-f7774ec33638bfc30cc29c1f70850a6072a31c93.tar.xz
cuberite-f7774ec33638bfc30cc29c1f70850a6072a31c93.tar.zst
cuberite-f7774ec33638bfc30cc29c1f70850a6072a31c93.zip
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt11
1 files changed, 6 insertions, 5 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index db9c61082..6b5efbd1f 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,6 +1,7 @@
cmake_minimum_required (VERSION 2.8.2)
project (MCServer)
+
include_directories (SYSTEM "${CMAKE_CURRENT_SOURCE_DIR}/../lib/")
include_directories (SYSTEM "${CMAKE_CURRENT_SOURCE_DIR}/../lib/jsoncpp/include")
include_directories (SYSTEM "${CMAKE_CURRENT_SOURCE_DIR}/../lib/polarssl/include")
@@ -41,8 +42,8 @@ SET (SRCS
LightingThread.cpp
LineBlockTracer.cpp
LinearInterpolation.cpp
- Log.cpp
- MCLogger.cpp
+ LoggerListeners.cpp
+ Logger.cpp
Map.cpp
MapManager.cpp
MobCensus.cpp
@@ -107,8 +108,8 @@ SET (HDRS
LineBlockTracer.h
LinearInterpolation.h
LinearUpscale.h
- Log.h
- MCLogger.h
+ Logger.h
+ LoggerListeners.h
Map.h
MapManager.h
Matrix4.h
@@ -234,7 +235,7 @@ endif()
# Generate a list of all source files:
-set(ALLFILES "")
+set(ALLFILES "${SRCS}" "${HDRS}")
foreach(folder ${FOLDERS})
get_directory_property(FOLDER_SRCS DIRECTORY ${folder} DEFINITION SRCS)
foreach (src ${FOLDER_SRCS})