summaryrefslogtreecommitdiffstats
path: root/src/UI/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2015-03-11 14:26:04 +0100
committerMattes D <github@xoft.cz>2015-03-11 14:26:04 +0100
commit1b60fe12a859287d1fc9f923fb2c85e30e7f9ad0 (patch)
tree961b0a521e31ba4f0a1b3516b49173c723ae24bd /src/UI/CMakeLists.txt
parentMerge pull request #1805 from mc-server/chunkDataFix (diff)
parentMoved window code into cpp files (diff)
downloadcuberite-1b60fe12a859287d1fc9f923fb2c85e30e7f9ad0.tar
cuberite-1b60fe12a859287d1fc9f923fb2c85e30e7f9ad0.tar.gz
cuberite-1b60fe12a859287d1fc9f923fb2c85e30e7f9ad0.tar.bz2
cuberite-1b60fe12a859287d1fc9f923fb2c85e30e7f9ad0.tar.lz
cuberite-1b60fe12a859287d1fc9f923fb2c85e30e7f9ad0.tar.xz
cuberite-1b60fe12a859287d1fc9f923fb2c85e30e7f9ad0.tar.zst
cuberite-1b60fe12a859287d1fc9f923fb2c85e30e7f9ad0.zip
Diffstat (limited to 'src/UI/CMakeLists.txt')
-rw-r--r--src/UI/CMakeLists.txt23
1 files changed, 22 insertions, 1 deletions
diff --git a/src/UI/CMakeLists.txt b/src/UI/CMakeLists.txt
index 2b094ef1d..ef4afc40a 100644
--- a/src/UI/CMakeLists.txt
+++ b/src/UI/CMakeLists.txt
@@ -6,11 +6,32 @@ include_directories ("${PROJECT_SOURCE_DIR}/../")
SET (SRCS
SlotArea.cpp
- Window.cpp)
+ Window.cpp
+ AnvilWindow.cpp
+ BeaconWindow.cpp
+ ChestWindow.cpp
+ CraftingWindow.cpp
+ DropSpenserWindow.cpp
+ EnchantingWindow.cpp
+ EnderChestWindow.cpp
+ FurnaceWindow.cpp
+ HopperWindow.cpp
+ InventoryWindow.cpp)
SET (HDRS
SlotArea.h
Window.h
+ AnvilWindow.h
+ BeaconWindow.h
+ ChestWindow.h
+ CraftingWindow.h
+ DropSpenserWindow.h
+ EnchantingWindow.h
+ EnderChestWindow.h
+ FurnaceWindow.h
+ HopperWindow.h
+ InventoryWindow.h
+ MinecartWithChestWindow.h
WindowOwner.h)
if(NOT MSVC)