summaryrefslogtreecommitdiffstats
path: root/src/mbedTLS++/CMakeLists.txt
diff options
context:
space:
mode:
authorpeterbell10 <peterbell10@live.co.uk>2017-08-30 16:00:06 +0200
committerTiger Wang <ziwei.tiger@outlook.com>2017-08-30 16:00:06 +0200
commit84941bcc9f25cbe3fd3b2604080d0a1cfd8fbaa7 (patch)
treeaa1648c2ba260b8576673677435481d371eec7b0 /src/mbedTLS++/CMakeLists.txt
parentUpdate core plugins to latest version (#3951) (diff)
downloadcuberite-84941bcc9f25cbe3fd3b2604080d0a1cfd8fbaa7.tar
cuberite-84941bcc9f25cbe3fd3b2604080d0a1cfd8fbaa7.tar.gz
cuberite-84941bcc9f25cbe3fd3b2604080d0a1cfd8fbaa7.tar.bz2
cuberite-84941bcc9f25cbe3fd3b2604080d0a1cfd8fbaa7.tar.lz
cuberite-84941bcc9f25cbe3fd3b2604080d0a1cfd8fbaa7.tar.xz
cuberite-84941bcc9f25cbe3fd3b2604080d0a1cfd8fbaa7.tar.zst
cuberite-84941bcc9f25cbe3fd3b2604080d0a1cfd8fbaa7.zip
Diffstat (limited to 'src/mbedTLS++/CMakeLists.txt')
-rw-r--r--src/mbedTLS++/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/mbedTLS++/CMakeLists.txt b/src/mbedTLS++/CMakeLists.txt
new file mode 100644
index 000000000..18ef22312
--- /dev/null
+++ b/src/mbedTLS++/CMakeLists.txt
@@ -0,0 +1,44 @@
+project (Cuberite)
+
+include_directories ("${PROJECT_SOURCE_DIR}/../")
+
+set(SRCS
+ AesCfb128Decryptor.cpp
+ AesCfb128Encryptor.cpp
+ BlockingSslClientSocket.cpp
+ BufferedSslContext.cpp
+ CallbackSslContext.cpp
+ CtrDrbgContext.cpp
+ CryptoKey.cpp
+ EntropyContext.cpp
+ RsaPrivateKey.cpp
+ Sha1Checksum.cpp
+ SslConfig.cpp
+ SslContext.cpp
+ X509Cert.cpp
+)
+
+set(HDRS
+ AesCfb128Decryptor.h
+ AesCfb128Encryptor.h
+ BlockingSslClientSocket.h
+ BufferedSslContext.h
+ CallbackSslContext.h
+ CtrDrbgContext.h
+ CryptoKey.h
+ EntropyContext.h
+ ErrorCodes.h
+ RsaPrivateKey.h
+ SslConfig.h
+ SslContext.h
+ Sha1Checksum.h
+ X509Cert.h
+)
+
+if(NOT MSVC)
+ add_library(mbedTLS++ ${SRCS} ${HDRS})
+
+ if (UNIX)
+ target_link_libraries(mbedTLS++ mbedtls)
+ endif()
+endif()