summaryrefslogtreecommitdiffstats
path: root/tests/ProtocolBlockTypePalette/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2019-12-02 16:45:55 +0100
committerMattes D <github@xoft.cz>2019-12-28 22:43:35 +0100
commit7453a9fbe120f345625a24bbea18c35cd3c26a6a (patch)
treee97cc9c90fedcad6e44f4011f0fdc4d2f6a284bf /tests/ProtocolBlockTypePalette/CMakeLists.txt
parentBlockTypePalette: Refactored for usage in both directions. (diff)
downloadcuberite-7453a9fbe120f345625a24bbea18c35cd3c26a6a.tar
cuberite-7453a9fbe120f345625a24bbea18c35cd3c26a6a.tar.gz
cuberite-7453a9fbe120f345625a24bbea18c35cd3c26a6a.tar.bz2
cuberite-7453a9fbe120f345625a24bbea18c35cd3c26a6a.tar.lz
cuberite-7453a9fbe120f345625a24bbea18c35cd3c26a6a.tar.xz
cuberite-7453a9fbe120f345625a24bbea18c35cd3c26a6a.tar.zst
cuberite-7453a9fbe120f345625a24bbea18c35cd3c26a6a.zip
Diffstat (limited to 'tests/ProtocolBlockTypePalette/CMakeLists.txt')
-rw-r--r--tests/ProtocolBlockTypePalette/CMakeLists.txt47
1 files changed, 0 insertions, 47 deletions
diff --git a/tests/ProtocolBlockTypePalette/CMakeLists.txt b/tests/ProtocolBlockTypePalette/CMakeLists.txt
deleted file mode 100644
index 43c2df676..000000000
--- a/tests/ProtocolBlockTypePalette/CMakeLists.txt
+++ /dev/null
@@ -1,47 +0,0 @@
-cmake_minimum_required(VERSION 3.0.2)
-enable_testing()
-add_definitions(-DTEST_GLOBALS=1)
-
-include_directories(SYSTEM "../../lib/jsoncpp/include")
-include_directories(${CMAKE_SOURCE_DIR}/src/)
-
-
-add_definitions(-DTEST_GLOBALS=1)
-
-set (SHARED_SRCS
- ${CMAKE_SOURCE_DIR}/src/Protocol/ProtocolBlockTypePalette.cpp
- ${CMAKE_SOURCE_DIR}/src/BlockState.cpp
- ${CMAKE_SOURCE_DIR}/src/StringUtils.cpp
-)
-
-set (SHARED_HDRS
- ../TestHelpers.h
- ${CMAKE_SOURCE_DIR}/src/Protocol/ProtocolBlockTypePalette.h
- ${CMAKE_SOURCE_DIR}/src/BlockState.h
- ${CMAKE_SOURCE_DIR}/src/StringUtils.h
-)
-
-set (SRCS
- ProtocolBlockTypePaletteTest.cpp
-)
-
-file (COPY
- test.btp.json
- ../../Server/Protocol/1.13/base.btp.json
- DESTINATION ./)
-
-source_group("Shared" FILES ${SHARED_SRCS} ${SHARED_HDRS})
-source_group("Sources" FILES ${SRCS})
-add_executable(ProtocolBlockTypePaletteTest-exe ${SRCS} ${SHARED_SRCS} ${SHARED_HDRS})
-target_link_libraries(ProtocolBlockTypePaletteTest-exe fmt::fmt jsoncpp_lib_static)
-add_test(NAME ProtocolBlockTypePaletteTest-test COMMAND ProtocolBlockTypePaletteTest-exe)
-
-
-
-
-
-# Put the projects into solution folders (MSVC):
-set_target_properties(
- ProtocolBlockTypePaletteTest-exe
- PROPERTIES FOLDER Tests
-)