summaryrefslogtreecommitdiffstats
path: root/Tools/ProtoProxy/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tools/ProtoProxy/CMakeLists.txt')
-rw-r--r--Tools/ProtoProxy/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Tools/ProtoProxy/CMakeLists.txt b/Tools/ProtoProxy/CMakeLists.txt
index 1c48d7d93..0d3ef3f3e 100644
--- a/Tools/ProtoProxy/CMakeLists.txt
+++ b/Tools/ProtoProxy/CMakeLists.txt
@@ -15,7 +15,8 @@ include_directories("../../lib/polarssl/include")
include_directories("../../src")
if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
- add_flags_cxx("-Wno-error=conversion")
+ add_flags_cxx("-Wno-error=sign-conversion -Wno-error=conversion -Wno-error=shorten-64-to-32 -Wno-error=keyword-macro")
+ add_flags_cxx("-Wno-error=old-style-cast")
endif()
function(flatten_files arg1)