summaryrefslogtreecommitdiffstats
path: root/src/Blocks/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Blocks/CMakeLists.txt')
-rw-r--r--src/Blocks/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Blocks/CMakeLists.txt b/src/Blocks/CMakeLists.txt
index d7ea6258f..d8affd9cf 100644
--- a/src/Blocks/CMakeLists.txt
+++ b/src/Blocks/CMakeLists.txt
@@ -95,6 +95,10 @@ SET (HDRS
MetaRotator.h
WorldInterface.h)
+if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+ set_source_files_properties(BlockHandler.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=old-style-cast")
+ set_source_files_properties(BlockPiston.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=old-style-cast")
+endif()
if(NOT MSVC)
add_library(Blocks ${SRCS} ${HDRS})