summaryrefslogtreecommitdiffstats
path: root/src/HTTP/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/HTTP/CMakeLists.txt')
-rw-r--r--src/HTTP/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/src/HTTP/CMakeLists.txt b/src/HTTP/CMakeLists.txt
new file mode 100644
index 000000000..4597f6eda
--- /dev/null
+++ b/src/HTTP/CMakeLists.txt
@@ -0,0 +1,45 @@
+
+cmake_minimum_required (VERSION 2.6)
+project (Cuberite)
+
+include_directories ("${PROJECT_SOURCE_DIR}/../")
+
+SET (SRCS
+ EnvelopeParser.cpp
+ HTTPFormParser.cpp
+ HTTPMessage.cpp
+ HTTPRequestParser.cpp
+ HTTPResponseParser.cpp
+ HTTPServer.cpp
+ HTTPServerConnection.cpp
+ MultipartParser.cpp
+ NameValueParser.cpp
+ SslHTTPServerConnection.cpp
+ TransferEncodingParser.cpp
+ UrlParser.cpp
+)
+
+SET (HDRS
+ EnvelopeParser.h
+ HTTPFormParser.h
+ HTTPMessage.h
+ HTTPRequestParser.h
+ HTTPResponseParser.h
+ HTTPServer.h
+ HTTPServerConnection.h
+ MultipartParser.h
+ NameValueParser.h
+ SslHTTPServerConnection.h
+ TransferEncodingParser.h
+ UrlParser.h
+)
+
+if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+ set_source_files_properties(HTTPServer.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=global-constructors ")
+ set_source_files_properties(HTTPServerConnection.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=switch-enum")
+ set_source_files_properties(HTTPMessage.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=tautological-compare")
+endif()
+
+if(NOT MSVC)
+ add_library(HTTPServer ${SRCS} ${HDRS})
+endif()