summaryrefslogtreecommitdiffstats
path: root/src/Noise/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Noise/CMakeLists.txt')
-rw-r--r--src/Noise/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Noise/CMakeLists.txt b/src/Noise/CMakeLists.txt
index e1837500f..ab4cf031b 100644
--- a/src/Noise/CMakeLists.txt
+++ b/src/Noise/CMakeLists.txt
@@ -14,6 +14,10 @@ SET (HDRS
RidgedNoise.h
)
+if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+ set_source_files_properties(Noise.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=old-style-cast")
+endif()
+
if(NOT MSVC)
add_library(Noise ${SRCS} ${HDRS})