summaryrefslogtreecommitdiffstats
path: root/src/PolarSSL++/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/PolarSSL++/CMakeLists.txt')
-rw-r--r--src/PolarSSL++/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/PolarSSL++/CMakeLists.txt b/src/PolarSSL++/CMakeLists.txt
index b11d16e33..fddb37501 100644
--- a/src/PolarSSL++/CMakeLists.txt
+++ b/src/PolarSSL++/CMakeLists.txt
@@ -33,6 +33,10 @@ set(HDRS
X509Cert.h
)
+if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+ set_source_files_properties(RsaPrivateKey.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=old-style-cast")
+endif()
+
if(NOT MSVC)
add_library(PolarSSL++ ${SRCS} ${HDRS})