summaryrefslogtreecommitdiffstats
path: root/tests/FastRandom/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/FastRandom/CMakeLists.txt')
-rw-r--r--tests/FastRandom/CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/tests/FastRandom/CMakeLists.txt b/tests/FastRandom/CMakeLists.txt
index a9d62bf94..df7492c5f 100644
--- a/tests/FastRandom/CMakeLists.txt
+++ b/tests/FastRandom/CMakeLists.txt
@@ -8,22 +8,19 @@ add_definitions(-DTEST_GLOBALS=1)
set (SHARED_SRCS
${CMAKE_SOURCE_DIR}/src/FastRandom.cpp
${CMAKE_SOURCE_DIR}/src/OSSupport/StackTrace.cpp
+ ${CMAKE_SOURCE_DIR}/src/OSSupport/WinStackWalker.cpp
)
set (SHARED_HDRS
${CMAKE_SOURCE_DIR}/src/FastRandom.h
${CMAKE_SOURCE_DIR}/src/OSSupport/StackTrace.h
+ ${CMAKE_SOURCE_DIR}/src/OSSupport/WinStackWalker.h
)
set (SRCS
FastRandomTest.cpp
)
-if (MSVC)
- # Add the MSVC-specific LeakFinder / StackTracer sources:
- list (APPEND SHARED_SRCS ${CMAKE_SOURCE_DIR}/src/LeakFinder.cpp ${CMAKE_SOURCE_DIR}/src/StackWalker.cpp)
- list (APPEND SHARED_HDRS ${CMAKE_SOURCE_DIR}/src/LeakFinder.h ${CMAKE_SOURCE_DIR}/src/StackWalker.h)
-endif()
source_group("Shared" FILES ${SHARED_SRCS} ${SHARED_HDRS})
source_group("Sources" FILES ${SRCS})