summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYuri Kunde Schlesner <yuriks@yuriks.net>2017-06-18 09:27:12 +0200
committerGitHub <noreply@github.com>2017-06-18 09:27:12 +0200
commit7dc72daea9603ec7329aef03259b7bafc97f9209 (patch)
treeb95f0b6bd7864f73247387f7698433d98d138885 /CMakeLists.txt
parentMerge pull request #2762 from wwylele/light-cp-tangent (diff)
parentCMake: Set MSVC flags for improved C++ standards conformance (diff)
downloadyuzu-7dc72daea9603ec7329aef03259b7bafc97f9209.tar
yuzu-7dc72daea9603ec7329aef03259b7bafc97f9209.tar.gz
yuzu-7dc72daea9603ec7329aef03259b7bafc97f9209.tar.bz2
yuzu-7dc72daea9603ec7329aef03259b7bafc97f9209.tar.lz
yuzu-7dc72daea9603ec7329aef03259b7bafc97f9209.tar.xz
yuzu-7dc72daea9603ec7329aef03259b7bafc97f9209.tar.zst
yuzu-7dc72daea9603ec7329aef03259b7bafc97f9209.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1f0af2d41..a61dee6e0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -92,10 +92,13 @@ else()
# /W3 - Level 3 warnings
# /MP - Multi-threaded compilation
# /Zi - Output debugging information
- # /Zo - enahnced debug info for optimized builds
- set(CMAKE_C_FLAGS "/W3 /MP /Zi /Zo" CACHE STRING "" FORCE)
+ # /Zo - enhanced debug info for optimized builds
+ # /permissive- - enables stricter C++ standards conformance checks
+ set(CMAKE_C_FLAGS "/W3 /MP /Zi /Zo /permissive-" CACHE STRING "" FORCE)
# /EHsc - C++-only exception handling semantics
- set(CMAKE_CXX_FLAGS "${CMAKE_C_FLAGS} /EHsc" CACHE STRING "" FORCE)
+ # /Zc:throwingNew - let codegen assume `operator new` will never return null
+ # /Zc:inline - let codegen omit inline functions in object files
+ set(CMAKE_CXX_FLAGS "${CMAKE_C_FLAGS} /EHsc /Zc:throwingNew,inline" CACHE STRING "" FORCE)
# /MDd - Multi-threaded Debug Runtime DLL
set(CMAKE_C_FLAGS_DEBUG "/Od /MDd" CACHE STRING "" FORCE)